实验8-1 网络地址转换之静态内部源地址转换NAT

曾巧文 发布于:2011-12-5 5:41 分类:计算机网络 标签: NAT

1.实验背景

    地址转换是在IPV4地址日益短缺的情况下提出的,如果一个局域网内部有很多台主机,但不能保证每台主机都拥有合法的IP地址,为了使所有内部主机都可以连接Internet网络,可以使用地址转换,地址转换技术可以有效地隐藏内部局域网中的主机,因此同时是有效的网络安全保护技术,地址转换可以根据用户需要,在局域网内部提供给外部FTPWWWTelnet服务。

2.实验环境

网络地址转换之静态内部源地址转换NAT

14-3 NAT的实验配置图

【实验设备】R2624路由器(2)

    本实验首先分别配置两台路由器R1R2的相应的端口IP地址,使他们所连接的网段能够互联,然后在R1上配置静态NAT,做地址转换。

3.实验步骤

1) Router1基本配置:

Red-Giant>enable       //从用户模式进入特权模式
Pssword:               //输入特权模式口令
R1#configure terminal //从特权模式进入全局配置模式
R1(config)#interface fastethernet 1 //进入路由器fastethernet 1的接口配置模式
R1(config-if)#ip address 172.16.1.1  255.255.255.0//设置路由器A fastethernet 1 的Ip地址为172.16.1.1,对应的子网掩码为255.255.255.0。该接口的IP地址为电脑本机所设的网关地址和掩码。
R1(config-if)#interface Serial 0  //进入路由器Serial 0的接口配置模式
R1(config-if)# ip address 202.116.64.3  255.255.255.0
2) Router2 的基本配置:配置串行接口Serial 0
R2(config-if)#interface Serial 0   //进入路由器Serial 0的接口配置模式
R2(config-if)# ip address 202.116.64.1 255.255.255.0 
R2(config-if)# clock rate 64000 //Router2为DCE,配置时钟频率
3) 在Router1上配置静态NAT映射
R1(config)# ip nat inside source static 172.16.1.2 202.116.64.2    //定义静态映射――匹配
R1(config)#interface fastethernet 0
R1(config)# ip nat inside      //定义内部接口
R1(config)# interface Serial 0
R1(config)# ip nat outside       //定义外部接口
R1(config)# ip route 0.0.0.0 0.0.0.0 Serial 0

验证测试Red-Giant# show ip nat translation

Pro   Inside global    Inside local     Outside local    Outside global

----  202.116.64.2     172.16.1.2       ------            -----

4注意事项

1)不要把insideoutside应用的接口弄错

2)要加上能使数据包向外转发的路由比如默认路由

3)尽量不要用广域网接口地址作为映射的全局地址。

测试: PC1 是否能pingRoute2S0接口(202.116.64.1),Route2pingPC1

版权所有:《曾巧文博客-关注互联网IT技术,记录生活点滴》 => 《实验8-1 网络地址转换之静态内部源地址转换NAT
本文地址://qiaowen.net/post-1127.html
除非注明,文章均为 《曾巧文博客-关注互联网IT技术,记录生活点滴》 原创,欢迎转载!转载请注明本文地址,谢谢。

有 4531 人浏览,获得评论 0 条

发表评论:

Powered by emlog 粤ICP备12040901号

>>本作品采用-知识共享署名-非商业-禁止演绎-协议-进行许可 |站点地图 | | | | 开放分类目录 |