实验8-2 网络地址转换之内部源地址转换NAPT

曾巧文 发布于:2011-12-5 10:42 分类:计算机网络 标签: NAPT

1.实验背景

      NAPT是在IP地址日益短缺的情况下提出的,如果一个公司内部有很多台主机,但该公司只申请了一个合法的公网IP地址,为了使所有内部主机都可以连接Internet网络,可以使用NAPT,使公司的所有主机在公网IP地址缺乏的情况下都能够访问外网。

2.实验环境

网络地址转换之内部源地址转换NAPT14-4 NAPT的实验配置图

【实验设备】 R2624路由器(2)

本实验首先分别配置两台路由器R1R2的端口IP地址如上图所示;然后在Router1上配置NAPT映射。

3.实验步骤

1)Router1基本配置:

Red-Giant>enable       //从用户模式进入特权模式
Pssword:               //输入特权模式口令
Red-Giant#configure terminal //从特权模式进入全局配置模式
Red-Giant(config)#interface fastethernet 1 //进入路由器fastethernet 1的接口配置模式
Red-Giant(config-if)#ip address 172.16.1.1  255.255.255.0//设置路由器A fastethernet 1 的Ip地址为172.16.1.1,对应的子网掩码为255.255.255.0。该接口的IP地址为电脑本机所设的网关地址和掩码。
Red-Giant(config-if)#interface Serial 0  //进入路由器Serial 0的接口配置模式
Red-Giant(config-if)# ip address 202.116.64.3  255.255.255.0

2)Router2 的基本配置:配置串行接口Serial 0

Red-Giant(config-if)#interface Serial 0//进入路由器Serial0的接口配置模式
Red-Giant(config-if)# ip address 202.116.64.1 255.255.255.0 
Red-Giant(config-if)# clock rate 64000 //Router2为DCE,配置时钟频率
3) 在Router1上配置NAPT映射
Red-Giant(config)# ip nat pool to-internet 202.116.64.2 202.116.64.2 netmask 255.255.255.0 overload    //定义地址池
Red-Giant(config)#access-list 1 permit 192.168.1.0 0.0.0.255 //定义允许转换的地址
Red-Giant(config)#interface fastethernet 0
Red-Giant(config)# ip nat inside      //定义内部接口
Red-Giant(config)# interface Serial 0
Red-Giant(config)# ip nat outside       //定义外部接口
Red-Giant(config)#ip nat source list 1 pool to-internet  //为内部本地调用转换池
Red-Giant(config)# ip route 0.0.0.0 0.0.0.0 Serial 0

验证测试:Red-Giant# show ip nat translation

Pro    Inside global      Inside local     Outside local    Outside global

----  202.116.64.2:2000  172.168.1.2       ------            -----

4.注意事项

1)不要把insideoutside应用的接口弄错;

2)要加上能使数据包向外转发的路由,比如默认路由;

3)尽量不要用广域网接口地址作为映射的全局地址,在本实验中由于设定仅有一个公网IP地址,所以使用广域网接口地址最为映射的全局地址。

版权所有:《曾巧文博客-关注互联网IT技术,记录生活点滴》 => 《实验8-2 网络地址转换之内部源地址转换NAPT
本文地址://qiaowen.net/post-1128.html
除非注明,文章均为 《曾巧文博客-关注互联网IT技术,记录生活点滴》 原创,欢迎转载!转载请注明本文地址,谢谢。

有 4797 人浏览,获得评论 0 条

发表评论:

Powered by emlog 粤ICP备12040901号

>>本作品采用-知识共享署名-非商业-禁止演绎-协议-进行许可 |站点地图 | | | | 开放分类目录 |